技术点滴

centos 6.x 版本不用编译直接升级gcc

在centos 6.x 上安装nodejs模块时,遇到该模块是C++扩展的,需要用node-gyp build.

而代码中用到了C11特性,但centos 6.x中gcc 版本较低,不支持C11.

需要升级gcc。网上讲的yum install centos-release-scl 不能使用。

换以下方法成功:

1)wget http://people.centos.org/tru/devtools-2/devtools-2.repo

2)cp devtools-2.repo /etc/yum.repos.d/

3)yum install devtoolset-2-gcc devtoolset-2-binutils devtoolset-2-gcc-c++

4)  scl enable devtoolset-2 bash



电话咨询
—— 售后咨询 ——
—— 商务合作 ——
微信咨询

售后咨询

商务咨询